Funktion VERGLEICH

Artikelübersicht


Beschreibung

Mit der Funktion VERGLEICH wird in einem Bereich von Zellen nach einem angegebenen Element gesucht und anschliessend die relative Position dieses Elements im Bereich zurückgegeben. Ein Beispiel: Wenn der Bereich A1:A3 die Werte «5», «25» und «38» enthält, gibt die Formel =VERGLEICH(25;A1:A3;0) den Wert «2» zurück, weil «25» der zweite Wert im Bereich ist.

Tipp: Verwenden Sie VERGLEICH immer dann statt einer der VERWEIS-Funktionen, wenn Sie die Position eines Elements in einem Bereich und nicht das Element selbst benötigen. Sie können die Funktion VERGLEICH beispielsweise verwenden, um einen Wert für das Argument Zeile in der INDEX-Funktion bereitzustellen.

Syntax

=VERGLEICH(Suchkriterium;Suchmatrix;[Vergleichstyp])

Die Syntax der Funktion VERGLEICH weist die folgenden Argumente auf:

  • Suchkriterium: Erforderlich. Der Wert, mit dem Sie Elemente in der Suchmatrix abgleichen möchten. Wenn Sie beispielsweise in einem Telefonbuch die Telefonnummer eines Bekannten suchen, verwenden Sie dessen Namen als Suchkriterium, obwohl die Telefonnummer der Wert ist, den Sie eigentlich wünschen.
    Bei dem Argument Suchkriterium kann es sich um einen Wert (Zahl, Text oder logischen Wert) oder einen Zellbezug auf eine Zahl, einen Text oder einen logischen Wert handeln.

  • Suchmatrix: Erforderlich. Der Zellbereich, der durchsucht wird.

  • Vergleichstyp: Optional. Die Zahl -1, 0 oder 1. Das Argument Vergleichstyp gibt an, auf welche Weise Excel die Werte in der Suchmatrix mit dem Wert für Suchkriterium abgleicht.

Vergleichstyp Verhalten
1 oder nicht angegeben VERGLEICH sucht nach dem grössten Wert, der kleiner oder gleich dem Wert für Suchkriterium ist. Die Werte im Argument Suchmatrix müssen in aufsteigender Reihenfolge angeordnet sein, z. B. ...-2, -1, 0, 1, 2, ..., A-Z, FALSCH, WAHR.
0 VERGLEICH sucht nach dem ersten Wert, der mit dem Wert für Suchkriterium genau übereinstimmt. Die Werte im Argument Suchmatrix dürfen in beliebiger Reihenfolge angeordnet sein.
-1 VERGLEICH sucht nach dem kleinsten Wert, der grösser oder gleich dem Wert für Suchkriterium ist. Die Werte im Argument Suchmatrix müssen in absteigender Reihenfolge angeordnet sein, z. B. WAHR, FALSCH, Z-A,...2, 1, 0, -1, -2,... usw.

Beispiel in Exceldatei

Laden Sie hier die dazugehörige Arbeitsmappe herunter: Beispiel-VERGLEICH

Im Beispiel unten soll in der Zelle B12 die Position des Kantons Zürich (steht in der Zelle B12), ermittelt werden. In der Zelle K2 soll die Position des Monats März (steht in der Zelle J2) ermittelt werden.


Die VERGLEICH-Funktion
Die VERWEIS-Funktion

  1. Klicken Sie auf die Zelle C12 und öffenen Sie den Funktionsassistenten mit hilfe des fx-Symbols.
  2. Wählen Sie die Funktion VERGLEICH.
  3. Für das Suchkriterium klicken Sie auf die Zelle B12.
  4. Für die Suchmatrix markieren Sie den Zellbereich B3 bis B10.
  5. Als Vergleichstyp tippen Sie eine 0, da eine genaue Übereinstimmung gefunden werden soll.
  6. Bestätigen Sie mit OK.

Verfahren Sie auf die gleiche Weise, um die Position des Monats März in der Zelle K2 zu ermitteln. Als Suchkriterium verwenden Sie die Zelle J2 und als Suchmatrix geben Sie den Bereich von der Zelle C2 bis H2.