Funktion ZÄHLENWENNS

Artikelübersicht


Beschreibung

Die Funktion ZÄHLENWENNS wendet Kriterien auf Zellen in mehreren Bereichen an und zählt, wie oft alle Kriterien zutreffen.

Syntax

=ZÄHLENWENNS(Kriterienbereich1;Kriterien1;[Kriterienbereich2; Kriterien2]…)

Die Syntax der Funktion ZÄHLENWENNS weist die folgenden Argumente auf:

  • Kriterienbereich1: Erforderlich. Der erste Bereich, in dem die zugehörigen Kriterien ausgewertet werden sollen.

  • Kriterien1: Erforderlich. Die Kriterien in Form einer Zahl, eines Ausdrucks, Zellbezugs oder Texts, mit denen definiert wird, welche Zellen gezählt werden. Kriterien können beispielsweise als 32, ">32", B4, "Äpfel" oder "32" angegeben werden.

  • Kriterienbereich2;Kriterien2; ...: Optional. Zusätzliche Bereiche und deren zugehörige Kriterien. Es sind bis zu 127 Bereich/Kriterien-Paare zulässig.

Wichtig: Jeder zusätzliche Bereich muss dieselbe Anzahl von Zeilen und Spalten wie das Argument Kriterienbereich1 haben. Die Bereiche müssen nicht direkt nebeneinander liegen.

Beispiele in Excel

ZÄHLENWENNS mit zwei Kriterien

Laden Sie hier die dazugehörige Arbeitsmappe herunter: Beispiel-ZÄHLENWENNS-1

Im Beispiel unten sollen die Wohneinheiten nach Kategorie (Spalten B bis C) gezählt werden. Zur Auswertung wurde eine Übersichtsliste mit den entsprechenden Kriterien erstellt. In der Zelle J2 soll die Anzahl der Wohneinheiten des Hauses 17 der Kategorie A berechnet werden.


Die ZÄHLENWENNS-Funktion mit zwei Kriterien
Die ZÄHLENWENNS-Funktion mit zwei Kriterien

  1. Klicken Sie in die Zelle J2 und tippen Sie =ZÄHLENWENNS. Sobald die Funktion ausgewählt ist, drücken Sie die Tabulator-Taste.
  2. Markieren Sie den Bereich von B2 bis zur Zelle B22 und drücken Sie danach die F4-Taste, damit die Bezüge absolut gesetzt werden.
  3. Tippen Sie ein Semikolon (;) und klicken Sie auf die Zelle H2 oder tippen Sie den Bezugsnamen, sollte ein Auswählen nicht möglich sein.
  4. Tippen Sie ein Semikolon (;) und markieren Sie den Bereich C2 bis und mit C22 und fixieren Sie ihn mit der F4-Taste.
  5. Tippen Sie nochmals ein Semikolon (;) und markieren Sie die Zelle I2, oder tippen Sie den Zellbezug, sollte ein Auswählen nicht möglich sein.
  6. Schliessen Sie die Klammer und bestätigen Sie mit der ENTER-Taste.

Die fertige Funktion sollte nun wie folgt aussehen: =ZÄHLENWENNS($B$2:$B$22;H2;$C$2:$C$22;I2)

Sie können die Funktion nach unten bis zur Zelle J4 ausfüllen. Ändern Sie in den Zellen H2 bis H4 die Einträge, werden die Wohneinheiten nach den neuen Kriterien berechnet.


ZÄHLENWENNS mit drei Kriterien

Laden Sie hier die dazugehörige Arbeitsmappe herunter: Beispiel-ZÄHLENWENNS-2

Im zweiten Beispiel muss schon ein wenig genauer hingeschaut werden, damit die Berechnung korrekt durchgeführt werden kann. Hier wird auch wieder das Haus 17 ausgewertet, diesmal werden als zweites Kriterium die Fläche zur Berechnung eingesetzt.

Beim zweiten Kriterium muss beachtet werden, dass hier die Wohnfläche einmal mit grösser als 80 m3 und ein zweitesmal mit grösser oder gleich 150 m3 berechnet werden soll. Damit dies korrekt ausgewertet werden kann, benötigen wir in der ZÄHLENWENNS-Funktion ein drittes Kriterium welches den Bereich zwischen 80 und 150 m3 eingrenzt.

Die Funktion in der Zelle J3 sieht dann folgendermassen aus: =ZÄHLENWENNS(B2:B22;H3;D2:D22;I3;D2:D22;"<150")


Die ZÄHLENWENNS-Funktion mit drei Kriterien
Die ZÄHLENWENNS-Funktion mit drei Kriterien